2 Commits
Author SHA1 Message Date
mags0ft 5f6c099504 further fixes for start.sh script 2025-11-15 15:15:17 +01:00
mags0ft be3de61c52 fix: correct logic for port validation in start.sh 2025-11-15 15:02:05 +01:00
2 changed files with 5 additions and 5 deletions
+1 -1
View File
@@ -33,7 +33,7 @@ WORKDIR /work
ADD ./src /work ADD ./src /work
# Install runpod and its dependencies # Install runpod and its dependencies
RUN pip install -r requirements.txt && chmod +x /work/start.sh RUN pip install -r ./requirements.txt && chmod +x /work/start.sh
# Set the entrypoint # Set the entrypoint
ENTRYPOINT ["/bin/sh", "-c", "/work/start.sh"] ENTRYPOINT ["/bin/sh", "-c", "/work/start.sh"]
+4 -4
View File
@@ -16,8 +16,8 @@ if [[ "$LLAMA_SERVER_CMD_ARGS" != *"/workspace"* ]]; then
echo "Tip: For reduced downloads and faster startup times, consider using a model stored in a network volume mounted to /workspace." echo "Tip: For reduced downloads and faster startup times, consider using a model stored in a network volume mounted to /workspace."
fi fi
# check if the substring -port is in LLAMA_SERVER_CMD_ARGS # check if the substring -port is in LLAMA_SERVER_CMD_ARGS and if yes, raise an error:
if [[ "$LLAMA_SERVER_CMD_ARGS" != *"-port"* ]]; then if [[ "$LLAMA_SERVER_CMD_ARGS" == *"-port"* ]]; then
echo "Error: You must not define -port in LLAMA_SERVER_CMD_ARGS, as port 3098 is required." echo "Error: You must not define -port in LLAMA_SERVER_CMD_ARGS, as port 3098 is required."
exit 1 exit 1
fi fi
@@ -26,13 +26,13 @@ fi
trap cleanup SIGINT SIGTERM trap cleanup SIGINT SIGTERM
# kill any existing llama-server processes # kill any existing llama-server processes
pgrep llama-server | xargs kill pkill llama-server
# we have a string with all the command line arguments in the env var LLAMA_SERVER_CMD_ARGS; # we have a string with all the command line arguments in the env var LLAMA_SERVER_CMD_ARGS;
# it contains a.e. "-hf modelname -ctx_size 4096". # it contains a.e. "-hf modelname -ctx_size 4096".
# We need to pass these arguments to llama-server verbatim. # We need to pass these arguments to llama-server verbatim.
llama-server $LLAMA_SERVER_CMD_ARGS -port 3098 2>&1 | tee llama.server.log & /app/llama-server $LLAMA_SERVER_CMD_ARGS -port 3098 2>&1 | tee llama.server.log &
LLAMA_SERVER_PID=$! # store the process ID (PID) of the background command LLAMA_SERVER_PID=$! # store the process ID (PID) of the background command